las tribulaciones técnicas de santib90

octubre 7, 2008

Error con Crystal Reports en servidor Windows 2003

Filed under: Uncategorized — Etiquetas: — santib90 @ 4:22 pm

Recientemente he estado desarrollando una aplicación web a medida con ASP.NET 2.0. Utilizo varios informes de Crystal Reports que funcionaban perfectamente desarrollando en local con VS 2005 pero al subirlos al servidor de daban un error de conectividad.

El error hacía referencia a que no podía conectar con el servidor y no era inmediatamente evidente porque el visor de informes me pedía unas nuevas credenciales de la conexión.

Tras buscar un buen rato con Google llegué al siguiente post de un tal Bret que explicaba el origen del problema.

Aunque yo no tengo los errores en el Event Viewer a los que él hace referencia el origen del problema resulta estar correcto. El infome estaba usando SQLNCLI en lugar de SQLOLEDB. Para corrregir el error simplemente localizar el informe, click con el boton derecho, elegir Database, luego Set Database Location, expandir el nodo Properties y cambiar SQLNCLI por SQLOLEDB si es necesario

report properties

report properties

Dejar un comentario »

Aún no hay comentarios.

RSS feed for comments on this post. TrackBack URI

Responder

Por favor, inicia sesión con uno de estos métodos para publicar tu comentario:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

Crea un blog o un sitio web gratuitos con WordPress.com.

A %d blogueros les gusta esto: